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PENDAHULUAN 

DASAR-DASAR HTML 

<HTML> 

HTML merupakan dasar atau tulang punggung dalam pembuatan sebuah Web. Dalam 

setiap file HTML akan selalu didahului dengan tag <HTML>. Tag ini akan membuat 

web browser mencoba untuk membaca file yang ada didalam tag tersebut untuk 

ditampilkan dalam web browser. Pada akhir baris jangan lupa Anda harus selalu 

mengakhiri tag <HTML> dengan </HTML>. Sehingga akan kelihatan bahwa pada 

setiap tag HTML akan selalu : 

<HTML> 

untuk mengakhiri : 

</HTML> 

Penulisan Tag HTML adalah incasesensitive. Artinya, <HTML> akan sama dengan 
<html> atau <Html>.  

Untuk selanjutnya akan dibagi menjadi 2 bagian: head dan body. 

<HEAD> 

Header akan berfungsi sebagai tanda pengenal pada halaman yang akan Anda buat. 

Untuk mendefinisikan header dalam tag HTML maka anda harus menambahkan 

<HEAD> dan </HEAD>  tag di bawah tag <HTML> dan akan menjadi seperti berikut: 

<HTML> 

<HEAD> 

</HEAD> 

</HTML> 

<BODY> 

Pada bagian body merupakan bagian dimana Anda dapat menuliskan berbagai text yang 

ingin Anda tampilkan pada halaman web. Untuk mendefinisikan body harus diketikan tag 

<BODY> dan ditutup dengan tag </BODY> dibawah tag header, sehingga akan 

terlihat: 

<HTML> 
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<HEAD> 

</HEAD> 

<BODY> 

</BODY> 

</HTML> 

MERENCANAKAN SEBUAH WEBSITE 

 

Dalam membuat website harus direncanakan terlebih  dahulu apa tujuan dari 

pembuatan website, informasi-informasi apa yang akan diberikan dan kepada siapa 

informasi-informasi tersebut dituju. 

Macromedia Dreamweaver adalah salah satu program pembuatan website yang 

mempunyai banyak sekali menu-menu dan tool-tool  yang dapat dipergunakan untuk 

mendesain website yang lebih kreatif dan membuat sebuah site yang komplit. Untuk 

mendapatkan hasil lebih bagus, harus didesain dan direncanakan lebih dahulu tiap-tiap 

halaman site yang ada. 

 

Rencana dan desain sebuah site 

Ketika memulai merencanakan membuat website, diharapkan melakukannya secara 

bertahap dan terencana untuk memastikan situs yang dibuat baik dan berhasil. Walaupun 

hanya akan membuat homepage pribadi yang hanya akan dilihat dan dikunjungi oleh 

teman dan keluarga. Bagi seorang pengajar situs pribadi bisa digunakan untuk 

memberikan informasi dan layanan ajar online untuk siswa . 

 

Menentukan tujuan Membuat Web site 

Menentukan tujuan site adalah langkah pertama kali yang harus diambil dalam 

pembuatan sebuah website. Tulis semua tujuan dan harapan dari pembuatan website, agar 

dapat mengingat saat proses mendesain website. Tujuan-tujuan tersebut akan sangat 

membantu agar tetap terfokus dan mempunyai target terhadap website yang diinginkan. 

Sebuah website yang memberikan berita-berita dengan subjek tertentu sangat berbeda 

dengan website yang menjual produk atau komersial. 

 

 

Memilih sasaran pengunjung situs 
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Setelah menentukan apa yang diinginkan untuk menyelesaikan website, tentukan 

siapa saja atau sasaran pengunjung situs.  

 

MEMBUAT, MEMBUKA, DAN MENYIMPAN DOKUMEN HTML 

Dreamweaver menawarkan berbagai macam cara untuk membuat suatu Dokumen, yaitu 

• membuat baru, dokumen HTML yang kosong;  

       pilih menu File > New 

• membuka dokumen HTML yang sudah ada 

       Pilih menu File > Open 

• jika untuk mempersingkat waktu dapat membuat dokumen baru berdasarkan 

template (blangko).  

Pilih menu File > New from Template. Akan tampak dialog box, daftar 

template-template yang ada (template terlebih dahulu harus dibuat sebelum membuat 

dokumen baru berdasarkan template) 

Pilih salah satu template. Dokumen baru akan dibuat berdasarkan template 

tersebut 

.  

Menyimpan dokumen : 

• Pilih menu File > Save. 

• Ketik nama file dan tentukan dimana file tersebut akan disimpan. 

   Catatan : Dreamweaver akan secara otomatis menyimpan file tersebut dalam bentuk 

htm  atau html. 

• Klik button Save untuk menyimpan file tersebut. 
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Mengatur document properties 

 

Judul halaman, background image, warna-warna teks dan warna link adalah dasar dari 

semua dokumen HTML. Judul halaman merupakan identitas dan nama dokumen. 

Background image atau gambar background dari suatu halaman (bisa juga memakai 

warna untuk background) diatur untuk keseluruhan tampilan dari dokumen tersebut. 

Teks dan warna link membantu pengunjung situs membedakan teks mana yang bisa 

link/masuk ke halaman lain, dan juga bisa membedakan dari warnanya apakah link 

tersebut sudah dikunjungi atau belum. 

Merubah judul halaman 

Judul dari halaman HTML memberitahu pengunjung site apa yang sedang pengunjung 

buka,  yang dapat dilihat pada menu bar windows dibawah. 

.Untuk mengganti judul halaman : 

Langkah-langkah : 

• Pilih menu Modify > Page Properties. 

• Klik kursor anda pada daerah kosong di halaman web. Lalu pilih Page Properties 

dengan mengklik kanan mouse anda. Masukkan judul untuk halaman tersebut 

pada title text box. 

Mengenal Lingkungan Kerja Dreamweaver MX 
Area kerja dreamweaverMX akan tampak seperti di bawah ini 

 
• Tampilan di atas adalah tampilan dimana dokumen yang akan dibuat dan diedit. 

Document Toolbar 

Property Inspector 

Insert Panel 

Document Window 

Judul 
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• Pada Insert panel terdapat icon-icon yang dapat diklik untuk memasukkan object 

pada dokumen dan untuk mengedit pembuatan halaman web. 

• Pada property inspector ditampilkan properti-properti dari object atau text yang 

dipilih dan dapat dimodifikasi (contoh = jenis text, ukuran text, dan sebagainya) 

• Untuk membuka tampilan windows, inspector dan panel-panel, gunakan menu 

Window. Beri tanda check untuk memilih tampilan mana yang diperlukan pada 

tampilan window. 

• Pada baris judul dari tampilan document window ditunjukkan judul halaman, 

nama folder dan nama file ada dalam tanda kurung.  

• Status bar, didapat pada bagian paling bawah document window, menunjukkan 

informasi-informasi tentang dokumen yang sedang dibuat. 

• Pada tag selector menampilkan HTML control pada text atau object yang dipilih. 

Klik salah satu text atau object maka pada tag selector akan tampak HTML 

control, contoh jika diklik pada dokumen window, pada tag selector akan tampak 

tulisan <body> disini menunjukkan sedang bekerja pada body dari dokumen 

secara HTML. 

 
 

 

• Pada Window size pop-up menu dapat dilihat dan mengedit ukuran window yang 

ditampilkan sesuai  keinginan 

• .Disebelah kanan menu window size pop-up dapat dilihat ukuran besarnya file 

dokumen dan waktu yang dibutuhkan untuk download file pada tampilan window. 

 

Catatan : Pada ukuran window menggambarkan ukuran dimensi pada browser. Untuk 

contoh, gunakan ukuran “536 x 196 (640 x 480, default)” jika pengunjung situs 

menggunakan Microsoft Internet Explorer atau Netscape Navigator, maka 

konfigurasi tampilannya adalah 640 x 480. 

 

TOOLBAR 

 
 

 

Tag Selection Window size  
pop-up menu 

Code View 

Code&Design  View 

Design View Nama File Tampilan Browser 
Refresh 
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Toolbar dreamweaver terdapat button-button yang dapat dipilih dalam menampilkan 

dokumen  secara cepat : Code (HTML), desain, dan gabungan keduanya yaitu tampilan 

secara HTML dan desain.Toolbar juga menampilkan button-button perintah yang 

terdapat pada sebelah kanan nama dokumen. 

• Untuk menampilkan dan menyembunyikan Toolbar, pilih menu View > Toolbar. 

• Untuk tampilan dokumen secara kode atau HTML , klik button Code View pada 

toolbar. Disini dapat diedit atau dibuat halaman web  secara HTML 

• Untuk tampilan dokumen secara kode dan desain, klik button Code & Design 

View 

• Untuk tampilan dokumen secara desain, klik button Design View, disini dapat 

diedit atau dibuat halaman web secara visual. 

• Untuk merubah nama dokumen, klik pada title lalu rubah nama dokumen sesuai 

dengan keinginan. 

• Untuk melihat halaman web secara browser (Internet Explorer) dengan mengklik 

button Preview Browser. 

 

OBJECT PANEL 

Pada Object panel terdapat button-button untuk membuat dan memasukkan object 

seperti tabel, layer dan images. Untuk menampilkan dan menyembunyikan Objects panel, 

pilih menu Window > Objects. 

 

 

Memasukkan sebuah Object : 

Klik icon button pada Object panel, tergantung pada object yang dipilih.  Setelah diklik 

salah satu button maka akan tampil Dialog Box yang harus diisi untuk memasukkan 

object tersebut. Object panel terdiri dari 7 kategori : Character, Common, Form, 

Frames, Head, Invisibles dan Special.  

Semua kategori tersebut menampilkan button untuk merubah tampilan : Standart dan 

Layout. Untuk saat ini kita hanya akan membicarakan kategori Common atau kategori 

yang umum dan biasa dipakai dan kategori Character. 

 

Common 

 
Kategori Common pada Object panel terdiri dari : 
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• Image  

Memasukkan sebuah gambar atau image pada cursor. Dialog Box akan tampil 

sehingga anda dapat secara spesifik memilih file image yang diinginkan. 

                      

• Rollover Image  

Secara khusus dapat dipilih 2 file image yang akan dimasukkan dan 

membuat 2 file image tersebut ditampilkan secara rollover. Rollover adalah bila 

sebuah gambar atau image akan berubah menjadi gambar yang lain bila mouse 

pointer dikenakan pada image tersebut. 

• Table  

Menempatkan atau membuat tabel. 

• Named Anchor. Untuk melakukan lompatan/link dari suatu teks atau gambar di 

halaman yang sama. 

• Navigation Bar Memasukkan beberapa image untuk Navigasi masuk ke site yang 

lain. 

• E-Mail Link Membuat link sebuah e-mail. 

• Date Menempatkan tanggal pada halaman web. Dialog Box akan muncul untuk 

spesifikasi format dari tanggal, Dreamweaver akan mengupdate dari tanggal 

secara otomatis setiap kali anda menyimpan file. 

• Fireworks HTML Memasukkan file HTML yang sudah dibuat atau sudah ada 

yang dibuat dari program Fireworks. 

• Flash Button Memasukkan Flash Button pada halaman web. 

• Flash Text Membuat Flash text object. 

• Shockwave Menempatkan movie dari Macromedia Shockwave pada halaman web. 

Dialog Box akan muncul agar dapat dipilih sumber file DCR daripada movie, atau 

dapat menggunakan Property inspector untuk menspesifikasi sumber file. 

• Generator Menempatkan object Macromedia Generator pada halaman web. 
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PROPERTY INSPECTOR 

 

Pada Property inspector  dapat memeriksa dan mengedit object atau teks  yang ada pada 

halaman web.  

 

• Untuk menampilkan atau menyembunyikan Property inspector,  

pilih menu Window > Properties. 

 

Dengan Property inspector object atau teks dapat diedit dengan cepat.(misalnya ingin 

merubah 

jenis fonts teks yang sudah dibuat dengan shadding teks lalu mengganti jenis font, atau 

pada object dapat merubah alamat URL atau link yang dituju). 

Tampilan Property inspector sangat bervariasi tergantung elemen yang dipilih. Untuk 

informasi properties yang spesifik, pilih elemen yang diinginkan pada dokumen window 

lalu klik icon Help pada pojok kanan atas pada Property inspector.  

 

Memilih Jenis Font 

Pada Property inspector bar, anda diberikan fasilitas dalam memilih jenis-jenis teks atau 

font untuk penulisan pada pembuatan halaman web. 

 
 

Mengatur format teks 

• Ukuran teks atau font dapat diatur pada kolom size 

• Align  teks dapat diatur dengan memilih button align 

• Membuat list numbering atau bullet 

 

Bekerja dengan  warna 

Help 

Align 

List numbering/bullet 
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Pada Dreamweaver, ada bermacam-macam dialog box, seperti juga pada Property inspector 

ada menu untuk kotak-kotak pilihan warna untuk teks. Tinggal dipilih warna-warna 

sesuai dengan keinginan. 

 
Memilih warna pada Dreamweaver : 

• Klik salah satu kotak warna pilihan. 

 

Hyperlink 

 

Membuat Hyperlink dari Property inspector 

 

Membuat hyperlink teks dari halaman yang dibuka ke halaman lain menggunakan 

fasilitas property inspector. 

1. Pilih teks yang akan dihyperlink. 

2. Shadding teks tersebut (tekan tombol kiri pada mouse, pilih teks yang akan di 

link), lalu pindahkan kursor pada property inspector bar, klik pada area Link ketik 

nama file yang dituju. 

3. Pindahkan kursor ke sembarang tempat, maka teks sudah hyperlink 

Dapat juga memilih tujuan link dengan membuka lambang folder, maka akan tampak 

dialog box, dimana  dapat dipilih file yang diinginkan. 
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Memasukkan Image atau gambar 

Ada 2 cara untuk memasukkan image pada Dreamweaver , dengan menggunakan main 

menu dan dengan menggunakan Object panel. 

1. Klik kursor pada tempat dimana ingin dimasukkan image. (coba diklik tempat 

paling atas pada dokumen) 

2. Pilih menu Insert > Image 

3. Tampak dialog box untuk memilih file image pilih image yang akan ditampilkan. 

4. Klik select, maka image tersebut akan masuk pada dokumen. 

Jika menggunakan cara dengan penggunaan Object panel  

Klik button insert image pada Object panel, maka akan tampak tampilan dialog 

box yang sama, lakukan seperti langkah sebelumnya. 

 

Membuat rollover image 

Rollover image adalah suatu image yang akan berubah ketika pointer dari mouse diarahkan 

pada image tersebut.  

Rolover image terdiri dari 2 gambar atau image: image pertama akan tampak pada saat 

pertama kali loading browser, dan image kedua akan tampak ketika pointer diarahkan pada 

image tersebut. Pastikan kedua image tersebut mempunyai ukuran yang sama, bila tidak 

sama maka tampilan site tampak tidak teratur. 

1. Klik button image rollover pada object panel 

2. Maka akan keluar dialog box yang harus diisi nama rollover image tersebut, 

memilih image pertama dan memilih rollover image atau image kedua , alamat url 

atau link yang dituju bila image tersebut diklik. 
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3. Klik option Preload image rollover, untuk memastikan image rollover tersebut 

jalan bila dibrowse. 

4. Klik OK untuk menutup dialog box tersebut bila sudah selesai. 

 
Rollover image hanya akan tampak pada browser 

• Tekan F12 , untuk  melihat dokumen pada web browser. 

Arahkan pointer anda pada image tersebut, maka akan tampak image yang 

berubah-ubah. 

• Ketika anda selesai melihat file tersebut dalam tampilan browser, tutup window 

browser tersebut. 

• Kembali dokumen anda pada Dreamweaver, pilih menu File > Save untuk 

menyimpan file anda tersebut. 

 

Memasukkan Flash Button 

Pada Macromedia Dreamweaver dapat langsung memasukkan Flash Button 

yang sangat dinamis dan animasi dalam berbagai macam bentuk. 

• Klik menu flash button pada Object panel. 

Maka akan keluar sebuah dialog box, yang harus diisi, dengan memilih bentuk-bentuk 

button, menulis teks dan jenis hingga ukuran teks yang akan ditampilkan pada button 

tersebut, memasukkan alamat halaman lain (link). 
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Memasukkan Flash Text 

Dreamweaver juga memberikan fasilitas hyperlink dengan flash text. 

1. Klik menu flash text pada Object panel , maka akan tampak dialog box yang 

harus diisi. 

2. Maka akan keluar dialog box yang harus diisikan properties dari teks (jenis teks, 

ukuran, align, dan sebagainya), hampir sama dengan rollover image, flash text 

dapat disebut rollover text. Tetapi hanya warna dari teks tersebut yang dapat 

berubah (rollover). 

3. Klik option show font, untuk memastikan textrollover tersebut jalan bila 

dibrowse. 

4. Klik OK untuk menutup dialog box tersebut bila sudah selesai. 

 
Flash text hanya akan tampak pada browser, tanpa perlu menyimpan (save) 

dokumen terlebih dahulu. 

• Tekan F12 untuk melihat dokumen pada web browser. 

Arahkan pointer anda pada image tersebut, maka akan tampak image yang 

berubah-ubah. 

• Ketika sudah selesai melihat file tersebut dalam tampilan browser, tutup window 

browser tersebut. 

Membuat jump menu  

Menu jump biasa digunakan sebagai navigasi yang akan "mengantar" pengunjung web 

untuk menuju halaman yang lainnya. Langkahnya adalah sebagai berikut :  
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1. Dari menu Insert, pilih Form - Jump Menu  

2. Pada bagian Text ketikkan nama item yang akan muncul pada menu list.  

3. Pada bagian When selected, Go to URL pilih file yang akan dibuka. 

 

Caranya dengan mengklik tombol Browse dan memilih file yang diinginkan, atau langsung 

ketikkan path file yang akan dibuka. Untuk file yang akan dibuka  bisa dipilih file pada situs 

yang sama atau bisa juga berupa alamat web, misalnya http://www.yahoo.com  

4. Jika ingin menambahkan tombol Go maka beri tanda check pada Insert Go Button After 

Menu  

5. Tekan tombol untuk memasukkan menu item ke dalam daftar.    

6. Ulangi langkah 2-5 untuk menu item yang lain.  

 

BEKERJA DENGAN TABEL & FRAME 

Tabel digunakan untuk memformat data dalam posisi-posisi kolom dan baris.  

Perpotongan antara baris dan kolom dinamakan sel, dan bisa memasukkan data di dalam 

sel tersebut. 

 

Memasukkan tabel 

Untuk memasukkan tabel ke dalam halaman homepage 

1. letakkan kursor ke tempat yang diinginkan. Kemudian, pilihlah satu diantara 3 

cara berikut ini : 

• Klik menu Insert – Table 

• Klik tombol “Insert table” pada Object Panel, kategori Common. 

• Tekan shortcut key : Ctrl+Alt+T 

Kemudian akan muncul kotak dialog Insert Table seperti ini : 
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Masukkan spesifikasi tabel yang diinginkan pada kotak dialog tersebut. 

2. Isikan jumlah baris pada “Rows” dan jumlah kolom pada “Columns”. 

3. Tentukan lebar tabel terhadap halaman.  

4. Masukkan lebar border tabel yang diinginkan dalam satuan pixel. Jika dikosongi 

maka dianggap 0 (nol) dan tabel tidak diberi border. 

5. Jika diinginkan, masukkan Cell Padding dan Cell Spacing.  

• Cell Spacing artinya jarak antar sel dalam tabel 

• Cell Padding artinya jarak dari border sel sampai dengan isi sel.  

6. Setelah selesai, klik tombol OK. Jika ingin membatalkan, tekan Cancel. 

Setelah menekan tombol OK, maka tabel akan dimasukkan dalam halaman web. 

Bentuknya kira-kira seperti ini (bisa berbeda-beda tergantung dari spesifikasi 

yang Anda masukkan tadi): 

 
Saat ini, tabel dikatakan dalam keadaan terpilih (selected), yang ditandai dengan 

adanya garis hitam tebal di sekeliling tabel, dan 3 buah kotak hitam kecil yang 

disediakan untuk resizing. Seperti yang terlihat pada window Object Properties, 

terdapat beberapa properti tabel yang disebutkan, antara lain : 

• Rows (jumlah baris) 

• Cols (jumlah kolom) 
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• W (lebar, width) 

• H (tinggi, height) 

• CellPad (cell padding) 

• CellSpace (cell spacing) 

• Align, Border 

• Bg Color (background color) 

• Brdr Color (border color) 

• Bg image (Bg image). 

 
 

Setiap perubahan pada window Object Properties ini akan dilakukan (applied) 

terhadap keseluruhan tabel, karena tabel dalam keadaan terpilih (selected).  

7. Langkah berikutnya adalah melakukan penyesuaian bentuk table menjadi yang 

diinginkan. 

 

Menambah atau mengurangi baris atau kolom 

Jika ingin menambah atau mengurangi baris atau kolom, langkah-langkah sebagai 

berikut: 

1. Letakkan kursor pada sel yang diinginkan. Ini berarti sel dalam keadaan terpilih. 

2. Klik tombol kanan mouse. Akan muncul menu konteks, pilihlah “Table”, kemudian 

muncul menu lagi. 

 
Pilihlah : 
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• “Insert Row”, untuk menyelipkan satu baris diatas sel yang terpilih. 

• “Insert Column”, untuk menyelipkan satu kolom di sebelah kiri sel yang terpilih. 

• “Insert Row or Column”, untuk menyelipkan baris atau kolom dengan menu 

interaktif seperti ini : 

 
Jika ingin menyelipkan baris,  

 klik pada radio button Rows, masukkan jumlah baris yang ingin 

diselipkan, 

 pilih apakah baris akan diselipkan di atas sel terpilih (Above the 

Selection) ataukah di bawah sel terpilih (Below the Selection). 

 Kemudian klik OK. 

Jika  ingin menyelipkan kolom,  

 klik pada radio button Columns (kotak dialog otomatis berganti), 

 masukkan jumlah kolom yang ingin diselipkan, kemudian pilih apakah 

kolom akan diselipkan sebelum sel terpilih (Before current Column) 

ataukah sesudah sel terpilih (After current Column).  

 Kemudian klik OK. 

• “Delete Row”, untuk menghapus baris pada sel yang terpilih tadi. 

• “Delete Column”, untuk menghapus kolom pada sel yang terpilih tadi. 

 

Mengubah lebar kolom atau tinggi baris (resize) 

 

Untuk mengubah lebar kolom atau tinggi baris, cara termudah adalah arahkan kursor 

mouse ke pinggir sel yang diinginkan sampai kursor mouse berubah menjadi :  , atau 

 
Kemudian drag (klik, tahan, geser) sementara ukuran kolom atau baris akan berubah. 

Lakukan sampai ukuran yang dinginkan, kemudian lepas tombol mouse. 
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Menggabungkan beberapa sel (merge) 

Untuk menggabungkan beberapa sel menjadi satu, pilih beberapa sel yang berdekatan 

dulu. Caranya,  

• arahkan mouse pada sel pertama (kiri atas atau kanan bawah),  

• kemudian drag beberapa sel sampai sel-sel yang diinginkan dalam keadaan terpilih 

(selected) semua.  

• klik kanan. Muncul menu konteks, pilih Table, kemudian Merge Cells. 

 
Maka hasilnya akan tampak seperti ini : 

 
Tampak bahwa grup sel yang terpilih tadi sekarang menjadi satu sel yang lebih besar. 

Yang perlu diperhatikan disini, jika ada 2 sel atau lebih yang memiliki isi di dalamnya 

(baik berupa tulisan, gambar, tabel, dsb) dan dilakukan operasi merge, maka isi-isi sel tadi 

akan dijadikan satu (dicampur) oleh Dreamweaver ™. 

 

Memecah satu sel (split) 

Untuk memecah satu sel menjadi beberapa sel yang lebih kecil 

• letakkan kursor pada sel yang ingin dipecah. Kemudian klik kanan mouse.  

• Muncul menu konteks, pilih Table, kemudian Split Cell. Maka muncul Split Cell 

dialog box seperti ini : 
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Jika ingin memecah sel tersebut menjadi beberapa baris 

• klik radio button Rows, 

• masukkan jumlah baris yang diinginkan 

• klik OK. 

Jika ingin memecah sel menjadi beberapa kolom 

• klik radio button Columns 

• masukkan jumlah kolom yang diinginkan 

• klik OK.  

 

Mengisi sel 

Setelah bentuk tabel sesuai, maka kita dapat mengisikan sesuatu ke dalam sel di 

dalam tabel. Sesuai dengan namanya, maka tabel dapat digunakan untuk mengisikan data 

dalam bentuk tabular. Untuk mengisikan data ke dalam sel, klik di dalam sel tersebut, 

kemudian mulai memasukkan data. 

Dalam setiap sel dapat dimasukkan tulisan, gambar, bahkan sebuah tabel. 

 

Frame 

Frame ialah cara untuk menampilkan beberapa halaman HTML dalam satu 

jendela browser. Yaitu dengan membagi-bagi satu jendela browser menjadi beberapa 

bagian, dimana tiap bagian menampilkan halaman HTML yang berbeda-beda. 

 
Untuk bekerja dengan frame, buat satu halaman baru sebagai frameset, dimana di dalam 

frameset ini terdapat beberapa halaman HTML untuk ditampilkan. Jadi, satu frameset bisa 

mengandung beberapa halaman HTML. 

Selama bekerja dengan frame, aktifkan  toolbar frame  

HTML HTML HTML
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Caranya : 

• klik menu Window, Frame (atau Shift+F2). 

 

• Object Properties juga sebaiknya dalam keadaan aktif (menu Window, Properties 

atau Ctrl+F3). 

 

 

Menambahkan dan mengaktifkan frame. 

Untuk menambahkan frame 

1. aktifkan dulu halaman yang akan ditambahkan frame, aktifkan juga toolbar 

layout. 

 

2. Klik button frame, sehingga muncul pilihan sbb : 

 
3. klik menu Insert, Frames, dan  

4. pilih salah satu : 

 Left, untuk menambahkan frame kecil di sebelah kiri 

 Right, untuk menambahkan frame kecil di sebelah kanan 

 Top, untuk menambahkan frame kecil di atas 

 Bottom, untuk menambahkan frame kecil di bawah 
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 Bottom and Nested Left Frame, untuk menambahkan frame di bawah dan 

kiri bersarang 

 Bottom and Nested Right Frame, untuk menambahkan frame di bawah dan 

kanan bersarang 

 Left and Nested Bottom Frame, untuk menambahkan frame di kiri dan 

bawah bersarang 

 Right and Nested Bottom Frame, untuk menambahkan frame di kanan dan 

bawah bersarang 

 Top and Bottom Frame, untuk menambahkan frame di atas dan di bawah 

 Left and Nested Top Frame, untuk menambahkan frame di kiri dan atas 

bersarang 

 Right and Nested Top Frame, untuk menambahkan frame di kanan dan atas 

bersarang 

 Top and Nested Left Frame, untuk menambahkan frame di atas dan kiri 

bersarang 

 Top and Nested Right Frame, untuk menambahkan frame di atas dan kanan 

bersarang 

 

Sebagai contoh, jika halaman HTML asalnya kosong, dan kemudian dimasukkan frame di 

sebelah kiri, maka halaman menjadi tampak seperti ini : 

 
Sedangkan window Frame menjadi seperti ini : 
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Lihat pada contoh gambar di atas. Saat ini, frame yang aktif adalah frame di sebelah kiri, 

yang ditandai dengan garis kotak tebal di sekeliling diagram.  

Jika ingin mengaktifkan frame yang lain, klik pada diagram yang mewakili frame yang  

diinginkan.  

Jika Anda ingin mengaktifkan frameset, maka klik di pinggiran diagram tersebut. 

 
Lihat pada diagram di atas, tampak bahwa garis tebal mengelilingi keseluruhan frame. 

Berarti, frameset sekarang dalam keadaan aktif. 

 

Mengubah properti frame 

 

Untuk mengubah properti frame, aktifkan frame yang akan diubah propertinya.  

Lihat pada window Object Properties. Tampak properti-properti yang dimiliki oleh 

sebuah frame. 

 
Penjelasan : 

• Frame Name adalah nama dari frame yang sedang aktif. Nama frame ini penting 

untuk dicatat karena dapat digunakan untuk membuat link lintas frame. 

• Src adalah nama file sumber dari frame yang sedang aktif. Untuk mengubah 

halaman yang ditampilkan, Anda dapat mengganti properti Src dengan salah satu 

file HTML yang telah dibuat. 
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• Scroll untuk menentukan apakah frame yang sedang aktif akan diberi scrollbar 

ataukah tidak. Jika dipilih Auto, maka scrollbar diberikan hanya jika dokumen 

tidak dapat ditampilkan dalam satu layar sehingga diberikan scrollbar. 

• No Resize : Jika dalam keadaan ter-cawang, maka frame tidak bisa diresize oleh 

user. Sedangkan jika tidak dalam keadaan ter-cawang, maka frame dapat di-resize 

oleh user. 

• Borders menentukan apakah frame diberi border. 

• Border Color menentukan warna dari border frame. 

 

Mengubah properti-properti frameset 

Untuk mengubah properti frameset, Aktifkan dahulu frameset-nya. Kemudian properti 

dapat diubah pada Object Properties. 

 
Penjelasan : 

• Borders menentukan apakah semua frame diberi border. 

• Border Width menentukan lebar border 

• Border Color menentukan warna border 

 

Mengubah ukuran dan menghapus frame 

1. Untuk mengubah ukuran frame, drag batas frame ke arah horizontal atau 

vertikal sampai ukuran yang diinginkan tercapai. 

2. Untuk menghapus frame, drag batas frame sampai ke luar Document 

Window. 

 

Save semua frame 

Yang perlu diingat dalam bekerja dengan frame yaitu sebelum mem-preview hasil 

pekerjaan, simpan semua frame yang telah dibentuk.  

Caranya : 

 klik menu File > Save All Frames.  

Maka akan ada perintah  untuk memberi nama file untuk frameset beserta frame-

frame yang ada di dalamnya. 
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Membuat link antar frame 

Link berguna untuk membawa user ke halaman lain atau men-download suatu file. 

Sebenarnya, suatu link dapat ditentukan apakah akan dibuka di jendela browser yang 

sama, jendela browser yang baru, atau dibuka di frame lain. 

Pada contoh, link akan dibuka di frame lain. 

 
 

Misalkan tersedia sebuah frameset (index.htm) dan di dalamnya terdapat 2 frame yaitu 

“leftFrame” (menu.htm) dan “mainFrame” (utama.htm). Kemudian akan dibuat sebuah 

link di leftFrame, yang mana link tersebut akan dibuka di mainFrame. 

Caranya : 

1. buatlah link di sebelah leftFrame seperti biasa, kemudian lihat pada Object 

Properties. 

2. Gantilah properti Target menjadi nama frame tujuan  diinginkan (mainFrame).  

 pilihan _blank berarti link dibuka di jendela browser baru, pilihan _parent 

berarti link dibuka di frameset paling pertama, 

 pilihan _self berarti link dibuka di frame dan jendela browser yang sama, 

 pilihan _top berarti link dibuka di frameset satu level diatas frame yang aktif, 

dan sisanya adalah nama-nama frame yang terdapat dalam halaman tersebut 

(jika memiliki 2 frame atau lebih dalam satu halaman). 



Pelatihan  Penyusunan  Sumber  Belajar  Matematika  Berbasis  Web  dengan  Menggunakan  Perangkat  Lunak 
Macromedia Dreamweaver bagi Guru Sekolah Menengah di Daerah Istimewa Yogyakarta 
Jurusan Pendidikan Matematika FMIPA UNY 8‐9 Agustus 2008 

 
 

26

Dengan menggunakan frame, dapat dibuat halaman navigasi sendiri dimana 

seluruh link dibuka di frame utama. Dengan demikian, user dapat menghemat waktu 

karena tidak perlu mendownload menu navigasi berkali-kali setiap mengakses halaman 

lain. 

 

Bekerja dengan Layer 

Layer merupakan salah satu keunggulan Dreamweaver dibandingkan dengan 

editor HTML lainnya. Dengan layer, kita dapat membuat halaman HTML yang 

tampilannya lebih fleksibel. Layer digunakan untuk menampilkan objek dengan posisi 

yang dapat diatur-atur sesuai keinginan, tanpa terbatas pada pandangan baris-demi-baris. 

Analoginya, layer diumpamakan sebagai plastik transparan yang dapat diletakkan dimana 

saja di atas kertas. 

Selama bekerja dengan layer, aktifkan  window Layers, Caranya : 

 klik menu Window > Layers. 

 
Memasukkan layer ke dalam dokumen 

Untuk memasukkan layer ke dalam dokumen : 

 klik menu Insert > Layout Object > Layer.  

Maka, akan muncul  : 

 
Dapat juga dimasukkan lebih dari satu layer ke dalam dokumen. Namun perlu 

diingat bahwa semakin banyak layer maka semakin besar pula ukuran dokumen. 

Setelah memasukkan layer ke dalam dokumen, maka window Layer akan menampilkan 

status dari semua layer yang ada di dalam dokumen. 
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Penjelasan : 

 Prevent Overlaps, berarti setiap layer yang ada akan dilarang untuk saling 

tumpang tindih. 

Tabel di dalam window Layers menampilkan semua layer yang ada pada 

dokumen. Urutannya yaitu dimulai dari yang paling atas sampai dengan paling 

bawah. Layer yang terletak di atas layer yang lain, akan ditampilkan lebih di atas 

(lebih kelihatan). 

 Kolom bergambar mata, menandakan layer apakah terlihat atau tidak. Kolom 

Name menandakan nama layer 

 kolom Z menandakan ketinggian layer.  Semakin besar Z, maka layer akan 

ditampilkan semakin terlihat (menutupi layer-layer lain dengan Z lebih kecil). 

Untuk mengubah urut-urutan ini, drag layer ke atas atau ke bawah atau 

mengubah nilai Z yang dimilikinya. 

 

Mengaktifkan layer 

Untuk mengaktifkan layer, klik pada pinggiran layer yang bersangkutan. 

 

Memindahkan dan mengubah ukuran layer 

Untuk memindahkan layer : 

 aktifkan dulu layer yang diinginkan 

 drag pinggiran layer ke tempat yang diinginkan. 

Untuk mengubah ukuran layer, Anda drag salah satu kotak di pinggiran layer sampai 

ukuran yang diinginkan tercapai. 

 

Mengubah properti-properti Layer 
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Untuk mengubah properti layer 

 aktifkan dahulu layer yang dinginkan 

 Lihat pada Object Properties. 

1. Properti L menandakan posisi horizontal layer terhadap pinggir kiri 

dokumen 

2. Properti T menandakan posisi vertikal layer terhadap bagian atas 

dokumen 

3. Properti W menandakan lebar layer 

4. Properti H menandakan tinggi layer 

5. Z-index adalah urutan layer 

6. Vis adalah visibility, dimana jika default atau visible, maka layer akan 

terlihat. Sedangkan bila invisible, maka layer tidak terlihat, jika inherit, 

maka layer akan menuruti sifat layer induknya. Bila layer induk visible 

maka ia juga visible. Begitu pula sebaliknya. 

7. Bg Image adalah gambar latar belakang dari layer 

8. Bg Color adalah warna latar belakang dari layer 

 

Mengisi objek ke dalam layer 

Untuk mengisikan objek ke dalam layer 

 klik kiri mouse di atas layer yang diinginkan 

 mulai mengetik atau memasukkan gambar, table, dan objek-objek lain. 

 
Pada gambar diatas, terdapat 2 buah layer, dimana layer pertama berada di bawah layer 

kedua karena Z-index layer pertama lebih kecil dari Z-index layer kedua. 
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 Jika dilihat hasilnya pada browser, maka pinggiran layer tidak akan terlihat. 

 

 


